ddi_dma_unbind_handle(9F)Kernel Functions for Driversddi_dma_unbind_handle(9F)

 ddi_dma_unbind_handle - unbinds the address in a DMA handle

 #include <sys/ddi.h>
 #include <sys/sunddi.h>

 int ddi_dma_unbind_handle(ddi_dma_handle_t handle);

 handle The DMA handle previously allocated by a call to
 ddi_dma_alloc_handle(9F).

 Solaris DDI specific (Solaris DDI).

 ddi_dma_unbind_handle() frees all DMA resources associated with an
 existing DMA handle. When a DMA transfer completes, the driver
 should call ddi_dma_unbind_handle() to free system DMA resources
 established by a call to ddi_dma_buf_bind_handle(9F) or
 ddi_dma_addr_bind_handle(9F). ddi_dma_unbind_handle() does an implicit
 ddi_dma_sync(9F) making further synchronization steps unnecessary.

 DDI_SUCCESS on success

 DDI_FAILURE on failure

 ddi_dma_unbind_handle() can be called from user, kernel, or interrupt
 context.

 ddi_dma_addr_bind_handle(9F), ddi_dma_alloc_handle(9F),
 ddi_dma_buf_bind_handle(9F), ddi_dma_free_handle(9F), ddi_dma_sync(9F)

 Writing Device Drivers

SunOS 5.11 26 Sep 1994 ddi_dma_unbind_handle(9F)