ddi_driver_name(9F) Kernel Functions for Drivers ddi_driver_name(9F)

 ddi_driver_name - return normalized driver name

 #include <sys/ddi.h>
 #include <sys/sunddi.h>

 const char *ddi_driver_name(dev_info_t *devi);

 Solaris DDI specific (Solaris DDI).

 dip A pointer to the device's dev_info structure.

 ddi_driver_name() returns the normalized driver name. This name is typ‐
 ically derived from the device name property or the device compatible
 property. If this name is a driver alias, the corresponding driver name
 is returned.

 ddi_driver_name() returns the actual name of the driver bound to a
 device.

 ddi_driver_name() can be called from kernel, or interrupt context.

 ddi_get_name(9F)

 Writing Device Drivers

 The name returned by ddi_driver_name() is read-only.

SunOS 5.11 2 Dec 1998 ddi_driver_name(9F)