ddi_fm_acc_err_clear(9F) Kernel Functions for Drivers ddi_fm_acc_err_clear(9F)

 ddi_fm_acc_err_clear, ddi_fm_dma_err_clear - clear the error status for
 an access or DMA handle

 #include <sys/ndifma.h>

 void ddi_fm_acc_err_clear(ddi_acc_handle_t acc_handle,
 int version);

 void ddi_fm_dma_err_clear(ddi_dma_handle_t dma_handle,
 int version);

 Solaris DDI specific (Solaris DDI)

 acc_handle Data access handle obtained from a previous call to
 ddi_regs_map_setup(9F), ddi_dma_mem_alloc(9F), or to a
 similar function.

 dma_handle DMA handle obtained from a previous call to
 ddi_dma_mem_alloc(9F) or one of its derivatives.

 version Version number of ddi_fm_error_t.

 The ddi_fm_dma_err_clear() and ddi_fm_acc_err_clear() functions clear
 the error status of a DMA or access handle respectively.

 Once cleared, the driver is again able to access the mapped registers
 or memory using programmed I/O through the handle.

 See attributes(5) for descriptions of the following attributes:

 ┌─────────────────────────────┬─────────────────────────────┐
 │ ATTRIBUTE TYPE │ ATTRIBUTE VALUE │
 ├─────────────────────────────┼─────────────────────────────┤
 │Interface Stability │Committed │
 └─────────────────────────────┴─────────────────────────────┘

 attributes(5), ddi_dma_mem_alloc(9F), ddi_fm_acc_err_get(9F),
 ddi_fm_dma_err_get(9F), ddi_regs_map_setup(9F)

 Writing Device Drivers

SunOS 5.11 10 May 2007 ddi_fm_acc_err_clear(9F)