ddi_get8(9F) Kernel Functions for Drivers ddi_get8(9F)

 ddi_get8, ddi_get16, ddi_get32, ddi_get64, ddi_getb, ddi_getw,
 ddi_getl, ddi_getll - read data from the mapped memory address, device
 register or allocated DMA memory address

 #include <sys/ddi.h>
 #include <sys/sunddi.h>

 uint8_t ddi_get8(ddi_acc_handle_t handle, uint8_t *dev_addr);

 uint16_t ddi_get16(ddi_acc_handle_t handle, uint16_t *dev_addr);

 uint32_t ddi_get32(ddi_acc_handle_t handle, uint32_t *dev_addr);

 uint64_t ddi_get64(ddi_acc_handle_t handle, uint64_t *dev_addr);

 Solaris DDI specific (Solaris DDI). The ddi_getb(), ddi_getl(),
 ddi_getll(), and ddi_getw() functions are obsolete. The ddi_get8()
 function replaces ddi_getb(). The ddi_get32() function replaces
 ddi_getl(). The ddi_get64() function replaces ddi_getll(). The
 ddi_get16() function replaces ddi_getw().

 handle The data access handle returned from setup calls, such as
 ddi_regs_map_setup(9F).

 dev_addr Base device address.

 The ddi_get8(), ddi_get16(), ddi_get32(), and ddi_get64() functions
 read 8 bits, 16 bits, 32 bits and 64 bits of data, respectively, from
 the device address, dev_addr.

 Each individual datum will automatically be translated to maintain a
 consistent view between the host and the device based on the encoded
 information in the data access handle. The translation may involve
 byte-swapping if the host and the device have incompatible endian char‐
 acteristics.

 For certain bus types, you can call these DDI functions from a high-
 interrupt context. These types include ISA and SBus buses. See sys‐
 bus(4), isa(4), and sbus(4) for details. For the PCI bus, you can,
 under certain conditions, call these DDI functions from a high-inter‐
 rupt context. See pci(4).

 These functions return the value read from the mapped address.

 These functions can be called from user, kernel, or interrupt context.

 See attributes(5) for descriptions of the following attributes:

 ┌─────────────────────────────┬─────────────────────────────┐
 │ ATTRIBUTE TYPE │ ATTRIBUTE VALUE │
 ├─────────────────────────────┼─────────────────────────────┤
 │Interface Stability │ddi_getb(), ddi_getl(), │
 │ │ddi_getll(), and ddi_getw() │
 │ │are Obsolete; ddi_get8(), │
 │ │ddi_get16(), ddi_get32(), │
 │ │ddi_get64() are Committed │
 └─────────────────────────────┴─────────────────────────────┘

 ddi_put8(9F), ddi_regs_map_free(9F), ddi_regs_map_setup(9F),
 ddi_rep_get8(9F), ddi_rep_put8(9F)

SunOS 5.11 1 Nov 2005 ddi_get8(9F)