ddi_get_lbolt(9F) Kernel Functions for Drivers ddi_get_lbolt(9F)

 ddi_get_lbolt - returns the value of lbolt

 #include <sys/types.h>
 #include <sys/ddi.h>
 #include <sys/sunddi.h>

 clock_t ddi_get_lbolt(void);

 Solaris DDI specific (Solaris DDI).

 ddi_get_lbolt() returns the value of lbolt where lbolt is an integer
 that represents the number of clock ticks since the last system reboot.
 This value is used as a counter or timer inside the system kernel. The
 tick frequency can be determined by using drv_usectohz(9F) which con‐
 verts microseconds into clock ticks.

 ddi_get_lbolt() returns the value of lbolt.

 This routine can be called from any context.

 ddi_get_time(9F), drv_getparm(9F), drv_usectohz(9F)

 Writing Device Drivers

 STREAMS Programming Guide

SunOS 5.11 18 Feb 1998 ddi_get_lbolt(9F)