ddi_binding_name(9F)     Kernel Functions for Drivers     ddi_binding_name(9F)

NAME

       ddi_binding_name, ddi_get_name - return driver binding name

SYNOPSIS

       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       char *ddi_binding_name(dev_info_t *dip);

       char *ddi_get_name(dev_info_t *dip);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

PARAMETERS

       dip     A pointer to the device's dev_info structure.

DESCRIPTION

       ddi_binding_name()  and  ddi_get_name() return the driver binding name.
       This is the name used to select a driver for the device. This  name  is
       typically derived from the device  name property or the device compatiā€
       ble property. The name returned may be a driver  alias  or  the  driver
       name.

RETURN VALUES

       ddi_binding_name()  and  ddi_get_name()  return the name used to bind a
       driver to a device.

CONTEXT

       ddi_binding_name() and ddi_get_name() can be called from user,  kernel,
       or interrupt context.

SEE ALSO

       ddi_node_name(9F)

       Writing Device Drivers

WARNINGS

       The  name  returned  by  ddi_binding_name() and ddi_get_name() is read-
       only.

SunOS 5.11                        3 May  1996             ddi_binding_name(9F)
Impressum