ddi_get_time(9F) Kernel Functions for Drivers ddi_get_time(9F)

 ddi_get_time - returns the current time in seconds

 #include <sys/types.h>
 #include <sys/ddi.h>
 #include <sys/sunddi.h>

 time_t ddi_get_time(void);

 Solaris DDI specific (Solaris DDI).

 ddi_get_time() returns the current time in seconds since 00:00:00 UTC,
 January 1, 1970. This value can be used to set of wait or expiration
 intervals.

 ddi_get_time() returns the time in seconds.

 This routine can be called from any context.

 ddi_get_lbolt(9F), drv_getparm(9F), drv_usectohz(9F)

 Writing Device Drivers

 STREAMS Programming Guide

SunOS 5.11 18 Feb 1998 ddi_get_time(9F)