ddi_mem_get8(9F) Kernel Functions for Drivers ddi_mem_get8(9F)

 ddi_mem_get8, ddi_mem_get16, ddi_mem_get32, ddi_mem_get64,
 ddi_mem_getb, ddi_mem_getl, ddi_mem_getll, ddi_mem_getw - read data
 from mapped device in the memory space or allocated DMA memory

 #include <sys/ddi.h>
 #include <sys/sunddi.h>

 uint8_t ddi_mem_get8(ddi_acc_handle_t handle, uint8_t *dev_addr);

 uint16_t ddi_mem_get16(ddi_acc_handle_t handle, uint16_t * dev_addr);

 uint32_t ddi_mem_get32(ddi_acc_handle_t handle, uint32_t *dev_addr);

 uint64_t ddi_mem_get64(ddi_acc_handle_t handle, uint64_t *dev_addr);

 Solaris DDI specific (Solaris DDI). The ddi_mem_get8(),
 ddi_mem_get16(), ddi_mem_get32(), ddi_mem_get64(), ddi_mem_getb(),
 ddi_mem_getl(), ddi_mem_getll(), and ddi_mem_getw() functions are obso‐
 lete. The ddi_get8(9F) function replaces ddi_mem_get8(). The
 ddi_get16(9F) function replaces ddi_mem_get16(). The ddi_get32(9F)
 function replaces ddi_mem_get32(). The ddi_get64(9F) function replaces
 ddi_mem_get64(). The ddi_get8(9F) function replaces ddi_mem_getb(). The
 ddi_get32(9F) function replaces ddi_mem_getl(). The ddi_get64(9F) func‐
 tion replaces ddi_mem_getll(). The ddi_get16(9F) function replaces
 ddi_mem_getw().

 handle The data access handle returned from setup calls, such as
 ddi_regs_map_setup(9F).

 dev_addr Base device address.

 These routines generate a read of various sizes from memory space or
 allocated DMA memory. The ddi_mem_get8(), ddi_mem_get16(),
 ddi_mem_get32(), and ddi_mem_get64() functions read 8 bits, 16 bits, 32
 bits and 64 bits of data, respectively, from the device address,
 dev_addr, in memory space.

 Each individual datum will automatically be translated to maintain a
 consistent view between the host and the device based on the encoded
 information in the data access handle. The translation may involve
 byte-swapping if the host and the device have incompatible endian char‐
 acteristics.

 These functions can be called from user, kernel, or interrupt context.

 See attributes(5) for descriptions of the following attributes:

 ┌─────────────────────────────┬─────────────────────────────┐
 │ ATTRIBUTE TYPE │ ATTRIBUTE VALUE │
 ├─────────────────────────────┼─────────────────────────────┤
 │Interface Stability │Obsolete │
 └─────────────────────────────┴─────────────────────────────┘

 ddi_get8(9F), ddi_get16(9F), ddi_get32(9F), ddi_get64(9F),
 ddi_mem_put8(9F), ddi_mem_rep_get8(9F), ddi_mem_rep_put8(9F),
 ddi_regs_map_setup(9F), ddi_device_acc_attr(9S)

SunOS 5.11 1 Nov 2005 ddi_mem_get8(9F)