ddi_no_info(9F)          Kernel Functions for Drivers          ddi_no_info(9F)

NAME

       ddi_no_info - stub for getinfo(9E)

SYNOPSIS

       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       int ddi_no_info(dev_info_t *dip, ddi_info_cmd_t infocmd, void *arg,
           void **result

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI)

PARAMETERS

       dev_info_t *dip           Pointer to dev_info structure.

       ddi_info_cmd_t infocmd    Command  argument.  Valid command values are:
                                 DDI_INFO_DEVT2DEVINFO                     and
                                 DDI_INFO_DEVT2INSTANCE.

       void *arg                 Command-specific argument.

       void **result             Pointer to where the requested information is
                                 stored.

DESCRIPTION

       The ddi_no_info() function always returns DDI_FAILURE. It  is  provided
       as  a convenience routine for drivers not providing a cb_ops(9S) or for
       network drivers only providing DLPI-2 services. Such  drivers  can  use
       ddi_no_info()  in the devo_getinfo entry point (see getinfo(9E)) of the
       dev_ops(9S) structure.

RETURN VALUES

       The ddi_no_info() function always returns DDI_FAILURE.

SEE ALSO

       getinfo(9E), qassociate(9F), cb_ops(9S), dev_ops(9S)

SunOS 5.11                        9 Jul 2002                   ddi_no_info(9F)
Impressum