ddi_root_node(9F)        Kernel Functions for Drivers        ddi_root_node(9F)

NAME

       ddi_root_node - get the root of the dev_info tree

SYNOPSIS

       #include <sys/conf.h>
       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       dev_info_t  *ddi_root_node(void);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

DESCRIPTION

       The  ddi_root_node() function returns a pointer to the root node of the
       device information tree.

RETURN VALUES

       The ddi_root_node() function returns a pointer to a device  information
       structure.

CONTEXT

       The  ddi_root_node()  function  can  be called from user, interrupt, or
       kernel context.

SEE ALSO

       Writing Device Drivers

SunOS 5.11                        16 Jan 2006                ddi_root_node(9F)
Impressum