flushband(9F)            Kernel Functions for Drivers            flushband(9F)

NAME

       flushband - flush messages for a specified priority band

SYNOPSIS

       #include <sys/stream.h>

       void flushband(queue_t *q, unsigned char pri, int flag);

INTERFACE LEVEL

       Architecture independent level 1 (DDI/DKI).

PARAMETERS

       q       Pointer to the queue.

       pri     Priority of messages to be flushed.

       flag    Valid flag values are:

       FLUSHDATA    Flush  only data messages (types M_DATA, M_DELAY, M_PROTO,
                    and M_PCPROTO ).

       FLUSHALL     Flush all messages.

DESCRIPTION

       The flushband() function flushes messages associated with the  priority
       band  specified by pri. If pri is 0, only normal and high priority mes‐
       sages are flushed. Otherwise, messages are flushed from  the  band  pri
       according to the value of flag.

CONTEXT

       The  flushband() function can be called from user, interrupt, or kernel
       context.

SEE ALSO

       flushq(9F)

       Writing Device Drivers STREAMS Programming Guide

SunOS 5.11                        16 Jan 2006                    flushband(9F)
Impressum