geterror(9F) Kernel Functions for Drivers geterror(9F)

 geterror - return I/O error

 #include <sys/types.h>
 #include <sys/buf.h>
 #include <sys/ddi.h>

 int geterror(struct buf *bp);

 Architecture independent level 1 (DDI/DKI).

 bp Pointer to a buf(9S) structure.

 The geterror() function returns the error number from the error field
 of the buffer header structure.

 An error number indicating the error condition of the I/O request is
 returned. If the I/O request completes successfully, 0 is returned.

 The geterror() function can be called from user, interrupt, or kernel
 context.

 buf(9S)

 Writing Device Drivers

SunOS 5.11 16 Jan 2006 geterror(9F)