getq(9F) Kernel Functions for Drivers getq(9F)

 getq - get the next message from a queue

 #include <sys/stream.h>

 mblk_t *getq(queue_t *q);

 Architecture independent level 1 (DDI/DKI).

 q Pointer to the queue from which the message is to be retrieved.

 The getq() function is used by a service ( srv(9E)) routine to retrieve
 its enqueued messages.

 A module or driver may include a service routine to process enqueued
 messages. Once the STREAMS scheduler calls srv() it must process all
 enqueued messages, unless prevented by flow control. getq() obtains the
 next available message from the top of the queue pointed to by q. It
 should be called in a while loop that is exited only when there are no
 more messages or flow control prevents further processing.

 If an attempt was made to write to the queue while it was blocked by
 flow control, getq() back-enables (restarts) the service routine once
 it falls below the low water mark.

 If there is a message to retrieve, getq() returns a pointer to it. If
 no message is queued, getq() returns a NULL pointer.

 The getq() function can be called from user, interrupt, or kernel con‐
 text.

 See dupb(9F).

 srv(9E), bcanput(9F), canput(9F), dupb(9F), putbq(9F), putq(9F), qen‐
 able(9F)

 Writing Device Drivers

 STREAMS Programming Guide

SunOS 5.11 16 Jan 2006 getq(9F)