hook_alloc(9F)           Kernel Functions for Drivers           hook_alloc(9F)

NAME

       hook_alloc - allocate a hook_t data structure

SYNOPSIS

       #include <sys/hook.h>

       hook_t *hook_alloc(const int version);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

PARAMETERS

       version    must always be the symbol HOOK_VERSION.

DESCRIPTION

       The  hook_alloc()  function  allocates  a hook_t structure, returning a
       pointer for the caller to use.

RETURN VALUES

       Upon success, hook_alloc() returns a pointer to  the  allocated  hook_t
       structure. On failure, hook_alloc() returns a NULL pointer.

CONTEXT

       The hook_alloc() function may be called from user  or kernel context.

ATTRIBUTES

       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE         │      ATTRIBUTE VALUE        │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability                 │SUNWcsu                      │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability          │Committed                    │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       hook_free(9F), hook_t(9S)

SunOS 5.11                        1 May 2008                    hook_alloc(9F)
Impressum