kstat_delete(9F)         Kernel Functions for Drivers         kstat_delete(9F)

NAME

       kstat_delete - remove a kstat from the system

SYNOPSIS

       #include <sys/types.h>
       #include <sys/kstat.h>

       void kstat_delete(kstat_t *ksp);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI)

PARAMETERS

       ksp     Pointer to a currently installed kstat(9S) structure.

DESCRIPTION

       kstat_delete()  removes  ksp from the kstat chain and frees all associā€
       ated system resources.

RETURN VALUES

       None.

CONTEXT

       kstat_delete() can be called from any context.

SEE ALSO

       kstat_create(9F), kstat_install(9F), kstat_named_init(9F), kstat(9S)

       Writing Device Drivers

NOTES

       When calling kstat_delete(),  the  driver  must  not  be  holding  that
       kstat's ks_lock. Otherwise, it may deadlock with a kstat reader.

SunOS 5.11                        4 Apr 1994                  kstat_delete(9F)
Impressum