ldi_devmap(9F)           Kernel Functions for Drivers           ldi_devmap(9F)

NAME

       ldi_devmap - Issue a devmap request to a device

SYNOPSIS

       #include <sys/sunldi.h>

       int ldi_devmap(ldi_handle_t lh, devmap_cookie_t dhp, offset_t off,
            size_t len, size_t *maplen, uint_t model);

PARAMETERS

       lh        Layered handle.

       dhp       Opaque mapping handle used by the system to describe mapping.

       off       User offset within the logical device memory at which mapping
                 begins.

       len       Mapping length (in bytes).

       maplen    Pointer to length (in bytes)  of  validated  mapping.   (Less
                 than or equal to len).

       model     Data model type of current thread.

DESCRIPTION

       The  ldi_devmap() function passes an devmap request to the device entry
       point for the device specified by the layered handle. This operation is
       supported for character devices.

RETURN VALUES

       The  ldi_devmap()  function returns 0 upon success. If a failure occurs
       before the request is passed to the device, possible return values  are
       shown  below.  Otherwise  any other error number may be returned by the
       device.

       EINVAL     Invalid input parameters.

       ENOTSUP    Operation is not supported for this device.

CONTEXT

       This function may be called from user or kernel context.

SunOS 5.11                        3 June 2003                   ldi_devmap(9F)
Impressum