ldi_ev_get_type(9F) Kernel Functions for Drivers ldi_ev_get_type(9F)

 ldi_ev_get_type - get event name string from event cookie

 #include <sys/sunldi.h>

 int ldi_ev_get_type(ldi_ev_cookie_t cookie);

 Solaris DDI specific (Solaris DDI)

 ldi_ev_cookie_t cookie

 An opaque event cookie for the event type returned by a previous
 call to ldi_ev_get_cookie(9F).

 The ldi_ev_get_type() function returns the event string represented by
 the LDI event cookie "cookie".

 On success, this function returns the event string represented by
 "cookie". On failure, this function returns NULL.

 This function can be called from user and kernel contexts only.

 ldi_ev_get_cookie(9F), ldi_ev_register_callbacks(9F),
 ldi_ev_remove_callbacks(9F)

SunOS 5.11 21 Aug 2007 ldi_ev_get_type(9F)