ldi_get_eventcookie(9F) Kernel Functions for Drivers ldi_get_eventcookie(9F)

 ldi_get_eventcookie - retrieve NDI event service cookie

 #include <sys/ddi_obsolete.h>

 int ldi_get_eventcookie(ldi_handle_t lh, char *name
 ddi_eventcookie_t *ecp);

 Obsolete

 ldi_handle_t lh Layered handle.

 char *name null-terminated string containing the event
 name.

 ddi_eventcookie_t *ecp Pointer to the kernel event cookie.

 This function is obsolete and is only maintained for compatibility. Use
 of this function is strongly discouraged. For equivalent functionality
 provided by new interfaces, see ldi_ev_get_cookie(9F) and ldi_ev_regisā
 ter_callbacks(9F).

 The ldi_get_eventcookie() function queries the device tree for a cookie
 matching the given event name and returns a reference to that cookie.
 The search is performed by calling up the device tree hierarchy of the
 device represented by the layered driver handle until the request is
 satisfied by a bus nexus driver, or the top of the dev_info tree is
 reached.

 The cookie returned by this function can be used to register a callback
 handler with ldi_add_event_handler(9F).

 DDI_SUCCESS Cookie handle is returned.

 DDI_FAILURE Request was not serviceable by any nexus driver in the
 target device's ancestral device tree hierarchy.

 This function may be called from user or kernel contexts.

 ldi_ev_get_cookie(9F), ldi_ev_register_callbacks(9F),
 ldi_add_event_handler(9F), ldi_remove_event_handler(9F)

 Writing Device Drivers

SunOS 5.11 21 Aug 2007 ldi_get_eventcookie(9F)