ldi_ident_from_dev(9F) Kernel Functions for Drivers ldi_ident_from_dev(9F)

 ldi_ident_from_dev, ldi_ident_from_stream, ldi_ident_from_dip,
 ldi_ident_release - ldi cookie management

 #include <sys/sunldi.h>

 int ldi_ident_from_dip(dev_info_t *dip, ldi_ident_t *lip);

 int ldi_ident_from_dev(dev_t dev, ldi_ident_t *lip);

 int ldi_ident_from_stream(struct queue *sq, ldi_ident_t *lip);

 void ldi_ident_release(ldi_ident_t li);

 li ldi identifier

 lip ldi identifier pointer

 dip pointer to device info node

 dev device number

 sq pointer to a stream queue

 The ldi_ident_from_dev() function allocates and returns an ldi identi‐
 fier that is associated with the device number specified by dev. The
 new ldi identifier is returned in the ldi identifier pointer parameter
 lip.

 The ldi_ident_from_dip() function allocates and returns an ldi identi‐
 fier that is associated with the device info node pointed to by dip.
 The new ldi identifier is returned in the ldi identifier pointer
 parameter lip.

 The ldi_ident_from_stream() function allocates and returns an ldi iden‐
 tifier that is associated with the stream pointed to by queue. The new
 ldi identifier is returned in the ldi identifier pointer parameter lip.

 The ldi_ident_release() function releases an identifier that was allo‐
 cated by one of the ldi_ident_from_*() functions.

 The ldi_ident_from_dev(), ldi_ident_from_dip(), and
 ldi_ident_from_stream() functions return 0 upon success.

 All of these functions return EINVAL for invalid input parameters.

 These functions can be called from user or kernel context.

SunOS 5.11 26 Mar 2009 ldi_ident_from_dev(9F)