ldi_remove_event_handler(9KFe)rnel Functions for Drivelrdsi_remove_event_handler(9F)

NAME

       ldi_remove_event_handler - remove an NDI event service callback

SYNOPSIS

       #include <sys/ddi_obsolete.h>

       int ldi_remove_event_handler(ldi_handle_t lh,
            ldi_callback_id_t id);

INTERFACE LEVEL

       Obsolete

PARAMETERS

       ldi_handle_t lh         Layered  handle  representing  the  device  for
                               which the event notification is requested.

       ldi_callback_id_t id    Unique system-wide registration ID returned  by
                               ldi_add_event_handler(9F)  upon successful reg‐
                               istration.

DESCRIPTION

       This function is obsolete and is only maintained for compatibility. Use
       of  this function is strongly discouraged. For equivalent functionality
       provided  by  new  interfaces,  see  ldi_ev_register_callbacks(9F)  and
       ldi_ev_remove_callbacks(9F).

       The  ldi_remove_event_handler()  function  removes the callback handler
       specified by the registration ID (ldi_callback_id_t).  Upon  successful
       removal,  the  callback  handler  is removed from the system and is not
       invoked at the event occurance.

RETURN VALUES

       DDI_SUCCESS    Callback handler removed successfully.

       DDI_FAILURE    Failed to remove callback handler.

CONTEXT

       This function can be called from user and kernel contexts only.

SEE ALSO

       ldi_ev_register_callbacks(9F),             ldi_ev_remove_callbacks(9F),
       ldi_add_event_handler(9F), ldi_get_eventcookie(9F)

       Writing Device Drivers

SunOS 5.11                        21 Aug 2007     ldi_remove_event_handler(9F)
Impressum