max(9F)                  Kernel Functions for Drivers                  max(9F)

NAME

       max - return the larger of two integers

SYNOPSIS

       #include <sys/ddi.h>

       int max(int int1, int int2);

INTERFACE LEVEL

       Architecture independent level 1 (DDI/DKI).

PARAMETERS

       int1    The first integer.

       int2    The second integer.

DESCRIPTION

       The  max() function compares two signed integers and returns the larger
       of the two.

RETURN VALUES

       The larger of the two numbers.

CONTEXT

       The max() function can be called from user, interrupt, or  kernel  con‐
       text.

SEE ALSO

       min(9F)

       Writing Device Drivers

SunOS 5.11                        16 Jan 2006                          max(9F)
Impressum