msgpullup(9F) Kernel Functions for Drivers msgpullup(9F)

 msgpullup - concatenate bytes in a message

 #include <sys/stream.h>

 mblk_t *msgpullup(mblk_t *mp, ssize_t len);

 Architecture independent level 1 (DDI/DKI).

 mp Pointer to the message whose blocks are to be concatenated.

 len Number of bytes to concatenate.

 The msgpullup() function concatenates and aligns the first len data
 bytes of the message pointed to by mp, copying the data into a new mes‐
 sage. Any remaining bytes in the remaining message blocks will be
 copied and linked onto the new message. The original message is unal‐
 tered. If len equals −1, all data are concatenated. If len bytes of the
 same message type cannot be found, msgpullup() fails and returns NULL.

 The msgpullup function returns the following values:

 Non-null Successful completion. A pointer to the new message is
 returned.

 NULL An error occurred.

 The msgpullup() function can be called from user, interrupt, or kernel
 context.

 srv(9E), allocb(9F), pullupmsg(9F), msgb(9S)

 Writing Device Drivers

 STREAMS Programming Guide

 The msgpullup() function is a DKI-compliant replacement for the older
 pullupmsg(9F) routine. Users are strongly encouraged to use msgpullup()
 instead of pullupmsg(9F).

SunOS 5.11 16 Jan 2006 msgpullup(9F)