net_instance_unregister(9FK)ernel Functions for Drivernset_instance_unregister(9F)

NAME

       net_instance_unregister - disable a set of instances

SYNOPSIS

       #include <sys/neti.h>

       void net_instance_unregister(net_instance_t *instances);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

PARAMETERS

       instances    must be a pointer returned by net_instance_alloc(9F).

DESCRIPTION

       The  net_instance_unregister()  function  removes  the set of instances
       that were previously registered with the net_instance_register()  func‐
       tion.

RETURN VALUES

       If the net_instance_unregister() function succeeds, 0 is returned. Oth‐
       erwise, an error indicating the problem encountered.

CONTEXT

       The net_instance_unregister() function may be called from  user,   ker‐
       nel, or interrupt context.

ATTRIBUTES

       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE         │      ATTRIBUTE VALUE        │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability                 │SUNWcsu                      │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability          │Committed                    │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       net_instance_alloc(9F),    net_instance_register(9F),    attributes(5),
       net_instance_t(9S)

SunOS 5.11                        1 May 2008       net_instance_unregister(9F)
Impressum