net_phylookup(9F)        Kernel Functions for Drivers        net_phylookup(9F)

NAME

       net_phylookup - determine if a network interface name exists for a net‐
       work protocol

SYNOPSIS

       #include <sys/neti.h>

       phy_if_t net_phylookup(const net_data_t net, const char *name);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

PARAMETERS

       net     value  returned  from   a   successful   call   to   net_proto‐
               col_lookup(9F).

       name    name of the network interface to find.

DESCRIPTION

       The  net_phylookup()  function  attempts  to resolve the interface name
       passed in with the network protocol.

       When called successfully,  the  value  returned  represents  a  network
       interface that exists, at the time of the call, within the scope of the
       network interface. This value is only guaranteed to  be  unique  for  a
       name within the scope of the network protocol.

RETURN VALUES

       The  net_phylookup()  function returns -1 if it is not supported by the
       network  protocol,  and 0 if the named network interface does not exist
       (or  is  otherwise  unknown).  Otherwise, it returns  a  value  greater
       than 0 representing a network interface that  currently  exists  within
       the scope of this network protocol.

CONTEXT

       The  net_phylookup()  function  may  be  called  from user,  kernel, or
       interrupt context.

ATTRIBUTES

       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE         │      ATTRIBUTE VALUE        │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability                 │SUNWcsu                      │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability          │Committed                    │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       net_getifname(9F),     net_phygetnext(9F),     net_protocol_lookup(9F),
       attributes(5)

SunOS 5.11                        1 May 2008                 net_phylookup(9F)
Impressum