net_protocol_release(9F) Kernel Functions for Drivers net_protocol_release(9F)

NAME

       net_protocol_release  - indicate that a reference to a network protocol
       is no longer required

SYNOPSIS

       #include <sys/neti.h>

       int net_protocol_release(net_data_t *net);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

PARAMETERS

       net    value  returned   from   a   successful   call   to   net_proto‐
              col_lookup(9F).

DESCRIPTION

       The  net_protocol_release()  function indicates to the network informa‐
       tion framework that the caller is no longer interested in any knowledge
       about  the network protocol to which the parameter being passed through
       applies.

RETURN VALUES

       The net_protocol_release() function returns:

       -1    The value passed in is unknown to this framework.

       0     Successful completion.

       1     Unsuccessful because this  function  has  been  called  too  many
             times.

CONTEXT

       The  net_protocol_release()  function may be called from user,  kernel,
       or interrupt context.

ATTRIBUTES

       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE         │      ATTRIBUTE VALUE        │
       ├─────────────────────────────┼─────────────────────────────┤
       │Availability                 │SUNWcsu                      │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability          │Committed                    │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO

       net_protocol_lookup(9F), net_protocol_walk(9F), attributes(5)

SunOS 5.11                        1 May 2008          net_protocol_release(9F)
Impressum