nodev(9F)                Kernel Functions for Drivers                nodev(9F)

NAME

       nodev - error return function

SYNOPSIS

       #include <sys/conf.h>
       #include <sys/ddi.h>

       int nodev();

INTERFACE LEVEL

       Architecture independent level 1 (DDI/DKI).

DESCRIPTION

       nodev()  returns   ENXIO.  It  is intended to be used in the cb_ops(9S)
       data structure of a device driver for device entry points which are not
       supported  by  the  driver.  That is, it is an error to attempt to call
       such an entry point.

RETURN VALUES

       nodev() returns ENXIO.

CONTEXT

       nodev() can be only called from user context.

SEE ALSO

       nulldev(9F), cb_ops(9S)

       Writing Device Drivers

SunOS 5.11                        27 Jan 1993                        nodev(9F)
Impressum