pollwakeup(9F) Kernel Functions for Drivers pollwakeup(9F)

 pollwakeup - inform a process that an event has occurred

 #include <sys/poll.h>

 void pollwakeup(struct pollhead *php, short event);

 Architecture independent level 1 (DDI/DKI).

 php Pointer to a pollhead structure.

 event Event to notify the process about.

 The pollwakeup() function wakes a process waiting on the occurrence of
 an event. It should be called from a driver for each occurrence of an
 event. The pollhead structure will usually be associated with the
 driver's private data structure associated with the particular minor
 device where the event has occurred. See chpoll(9E) and poll(2) for
 more detail.

 The pollwakeup() function can be called from user, interrupt, or kernel
 context.

 poll(2), chpoll(9E)

 Writing Device Drivers

 Driver defined locks should not be held across calls to this function.

SunOS 5.11 16 Jan 2006 pollwakeup(9F)