ptob(9F)                 Kernel Functions for Drivers                 ptob(9F)

NAME

       ptob - convert size in pages to size in bytes

SYNOPSIS

       #include <sys/ddi.h>

       unsigned long ptob(unsigned long numpages);

INTERFACE LEVEL

       Architecture independent level 1 (DDI/DKI).

PARAMETERS

       numpages    Size in number of pages to convert to size in bytes.

DESCRIPTION

       This  function  returns  the  number of bytes that are contained in the
       specified number of pages. For example, if the page size is 2048,  then
       ptob(2) returns 4096. ptob(0) returns 0.

RETURN VALUES

       The  return value is always the number of bytes in the specified number
       of pages. There are no invalid input values, and no  checking  will  be
       performed  for overflow in the case of a page count whose corresponding
       byte count cannot be represented  by  an  unsigned  long.  Rather,  the
       higher order bits will be ignored.

CONTEXT

       The  ptob() function can be called from user, interrupt, or kernel con‐
       text.

SEE ALSO

       btop(9F), btopr(9F), ddi_ptob(9F)

       Writing Device Drivers

SunOS 5.11                        16 Jan 2006                         ptob(9F)
Impressum