putnext(9F) Kernel Functions for Drivers putnext(9F)

 putnext - send a message to the next queue

 #include <sys/stream.h>
 #include <sys/ddi.h>

 void putnext(queue_t *q, mblk_t *mp);

 Architecture independent level 1 (DDI/DKI).

 q Pointer to the queue from which the message mp will be sent.

 mp Message to be passed.

 The putnext() function is used to pass a message to the put(9E) routine
 of the next queue in the stream.

 None.

 The putnext() function can be called from user, interrupt, or kernel
 context.

 See allocb(9F) for an example of using putnext().

 put(9E), allocb(9F), put(9F), qprocson(9F)

 Writing Device Drivers

 STREAMS Programming Guide

 The put() and putnext() functions should be called only after qproc‐
 son() is finished.

SunOS 5.11 16 Jan 2006 putnext(9F)