qsize(9F)                Kernel Functions for Drivers                qsize(9F)

NAME

       qsize - find the number of messages on a queue

SYNOPSIS

       #include <sys/stream.h>

       int qsize(queue_t *q);

INTERFACE LEVEL

       Architecture independent level 1 (DDI/DKI).

PARAMETERS

       q    Queue to be evaluated.

DESCRIPTION

       The  qsize()  function  evaluates the queue q and returns the number of
       messages it contains.

RETURN VALUES

       If there are no message on the queue, qsize() returns 0. Otherwise,  it
       returns the integer representing the number of messages on the queue.

CONTEXT

       The qsize() function can be called from user, interrupt, or kernel con‐
       text.

SEE ALSO

       Writing Device Drivers

       STREAMS Programming Guide

SunOS 5.11                        16 Jan 2006                        qsize(9F)
Impressum