SAMESTR(9F) Kernel Functions for Drivers SAMESTR(9F)

 SAMESTR, samestr - test if next queue is in the same stream

 #include <sys/stream.h>

 int SAMESTR(queue_t *q);

 Architecture independent level 1 (DDI/DKI).

 q Pointer to the queue.

 The SAMESTR() function is used to see if the next queue in a stream (if
 it exists) is the same type as the current queue (that is, both are
 read queues or both are write queues). This function accounts for the
 twisted queue connections that occur in a STREAMS pipe and should be
 used in preference to direct examination of the q_next field of
 queue(9S) to see if the stream continues beyond q.

 The SAMESTR() function returns 1 if the next queue is the same type as
 the current queue. It returns 0 if the next queue does not exist or if
 it is not the same type.

 The SAMESTR() function can be called from user, interrupt, context.

 OTHERQ(9F)

 Writing Device Drivers

 STREAMS Programming Guide

SunOS 5.11 16 Jan 2006 SAMESTR(9F)