scsi_free_consistent_buf(9KFe)rnel Functions for Drivesrcssi_free_consistent_buf(9F)

 scsi_free_consistent_buf - free a previously allocated SCSI DMA I/O
 buffer

 #include <sys/scsi/scsi.h>

 void scsi_free_consistent_buf(struct buf *bp);

 Solaris DDI specific (Solaris DDI).

 bp Pointer to the buf(9S) structure.

 The scsi_free_consistent_buf() function frees a buffer header and con‐
 sistent data buffer that was previously allocated using scsi_alloc_con‐
 sistent_buf(9F).

 The scsi_free_consistent_buf() function can be called from user, inter‐
 rupt, or kernel context.

 freerbuf(9F), scsi_alloc_consistent_buf(9F), buf(9S)

 Writing Device Drivers

 The scsi_free_consistent_buf() function will call freerbuf(9F) to free
 the buf(9S) that was allocated before or during the call to
 scsi_alloc_consistent_buf(9F).

 If consistent memory is bound to a scsi_pkt(9S), the pkt should be
 destroyed before freeing the consistent memory.

SunOS 5.11 16 Jan 2006 scsi_free_consistent_buf(9F)