scsi_unprobe(9F)         Kernel Functions for Drivers         scsi_unprobe(9F)

NAME

       scsi_unprobe,  scsi_unslave  -  free resources allocated during initial
       probing

SYNOPSIS

       #include <sys/scsi/scsi.h>

       void scsi_unslave(struct scsi_device *devp);

       void scsi_unprobe(struct scsi_device *devp);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).  The  scsi_unslave()  interface  is
       obsolete. Use scsi_unprobe() instead.

PARAMETERS

       devp     Pointer to a scsi_device(9S) structure.

DESCRIPTION

       scsi_unprobe()  and  scsi_unslave() are used to free any resources that
       were  allocated  on  the  driver's  behalf  during  scsi_slave(9F)  and
       scsi_probe(9F) activity.

CONTEXT

       scsi_unprobe()  and scsi_unslave() must not be called from an interrupt
       context.

SEE ALSO

       scsi_probe(9F), scsi_slave(9F), scsi_device(9S)

       Writing Device Drivers

NOTES

       The scsi_unslave() function is obsolete and will be discontinued  in  a
       future release. This function has been replaced by scsi_unprobe().

SunOS 5.11                        27 Sep 2002                 scsi_unprobe(9F)
Impressum