ureadc(9F) Kernel Functions for Drivers ureadc(9F)

 ureadc - add character to a uio structure

 #include <sys/uio.h>
 #include <sys/types.h>

 int ureadc(int c, uio_t *uio_p);

 Architecture independent level 1 (DDI/DKI).

 c The character added to the uio(9S) structure.

 uio_p Pointer to the uio(9S) structure.

 The ureadc() function transfers the character c into the address space
 of the uio(9S) structure pointed to by uio_p, and updates the uio
 structure as for uiomove(9F).

 0 is returned on success and EFAULT on failure.

 The ureadc() function can be called from user, interrupt, or kernel
 context.

 uiomove(9F), uwritec(9F), iovec(9S), uio(9S)

 Writing Device Drivers

SunOS 5.11 16 Jan 2006 ureadc(9F)