uwritec(9F)              Kernel Functions for Drivers              uwritec(9F)

NAME

       uwritec - remove a character from a uio structure

SYNOPSIS

       #include <sys/uio.h>

       int uwritec(uio_t *uio_p);

INTERFACE LEVEL

       Architecture independent level 1 (DDI/DKI)

PARAMETERS

       uio_p    Pointer to the uio(9S) structure

DESCRIPTION

       The  uwritec()  function  returns  a  character  from the uio structure
       pointed to by uio_p and updates the uio structure. See uiomove(9F).

RETURN VALUES

       The next character for processing is returned on  success,  and  -1  is
       returned if uio is empty or if there is an error.

CONTEXT

       The  uwritec()  function  can be called from user, interrupt, or kernel
       context.

SEE ALSO

       uiomove(9F), ureadc(9F), iovec(9S), uio(9S)

       Writing Device Drivers

SunOS 5.11                        16 Jan 2006                      uwritec(9F)
Impressum