modldrv(9S)               Data Structures for Drivers              modldrv(9S)

NAME

       modldrv - linkage structure for loadable drivers

SYNOPSIS

       #include <sys/modctl.h>

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI)

DESCRIPTION

       The  modldrv  structure is used by device drivers to export driver spe‐
       cific information to the kernel.

STRUCTURE MEMBERS

         struct mod_ops    *drv_modops;
         char              *drv_linkinfo;
         struct dev_ops    *drv_dev_ops;

       drv_modops       Must  always  be  initialized  to   the   address   of
                        mod_driverops.  This member identifies the module as a
                        loadable driver.

       drv_linkinfo     Can be  any  string  up  to  MODMAXNAMELEN  characters
                        (including  the  terminating  NULL  character), and is
                        used to describe the module and  its  version  number.
                        This is usually the name of the driver and module ver‐
                        sion information, but can contain other information as
                        well.

       drv_dev_ops      Pointer to the driver's dev_ops(9S) structure.

SEE ALSO

       add_drv(1M), dev_ops(9S), modlinkage(9S)

       Writing Device Drivers

SunOS 5.11                        5 Mar 2001                       modldrv(9S)
Impressum