modlstrmod(9S) Data Structures for Drivers modlstrmod(9S)

 modlstrmod - linkage structure for loadable STREAMS modules

 #include <sys/modctl.h>

 Solaris DDI specific (Solaris DDI)

 The modlstrmod structure is used by STREAMS modules to export module
 specific information to the kernel.

 struct mod_ops *strmod_modops;
 char *strmod_linkinfo;
 struct fmodsw *strmod_fmodsw;

 strmod_modops Must always be initialized to the address of
 mod_strmodops. This identifies the module as a
 loadable STREAMS module.

 strmod_linkinfo Can be any string up to MODMAXNAMELEN, and is used
 to describe the module. This string is usually the
 name of the module, but can contain other informa‐
 tion (such as a version number).

 strmod_fmodsw Is a pointer to a template of a class entry within
 the module that is copied to the kernel's class ta‐
 ble when the module is loaded.

 modload(1M)

 Writing Device Drivers

SunOS 5.11 7 Jun 1993 modlstrmod(9S)