scsi_arq_status(9S)       Data Structures for Drivers      scsi_arq_status(9S)

NAME

       scsi_arq_status - SCSI auto request sense structure

SYNOPSIS

       #include <sys/scsi/scsi.h>

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI)

DESCRIPTION

       When  auto  request sense has been enabled using  scsi_ifsetcap(9F) and
       the "auto-rqsense" capability, the target driver must allocate a status
       area  in the SCSI packet structure for the auto request sense structure
       (see scsi_pkt(9S)).  In the event of a check condition,  the  transport
       layer  automatically  executes  a  request  sense  command.  This check
       ensures that the request sense information does not get lost. The  auto
       request  sense  structure supplies the SCSI status of the original com‐
       mand, the transport information pertaining to the  request  sense  com‐
       mand, and the request sense data.

STRUCTURE MEMBERS

         struct scsi_status       sts_status;          /* SCSI status */
         struct scsi_status       sts_rqpkt_status;    /* SCSI status of
                                                          request sense cmd */
         uchar_t                  sts_rqpkt_reason;    /* reason completion */
         uchar_t                  sts_rqpkt_resid;     /* residue */
         uint_t                   sts_rqpkt_state;     /* state of command */
         uint_t                   sts_rqpkt_statistics;/* statistics */
         struct scsi_extended_sense sts_sensedata;      /* actual sense data */

       sts_status  is  the  SCSI status of the original command. If the status
       indicates a check condition, the transport layer might  have  performed
       an auto request sense command.

       sts_rqpkt_status  is  the  SCSI  status  of  the request sense command.
       sts_rqpkt_reason is the completion reason of the request sense command.
       If  the reason is not CMD_CMPLT, then the request sense command did not
       complete normally.

       sts_rqpkt_resid is the residual count of the data  transfer  and  indi‐
       cates the number of data bytes that have not been transferred. The auto
       request sense command requests SENSE_LENGTH bytes.

       sts_rqpkt_state has bit positions representing the five most  important
       statuses that a  SCSI command can go obtain.

       sts_rqpkt_statistics  maintains  transport-related  statistics  of  the
       request sense command.

       sts_sensedata contains the actual sense data if the request sense  com‐
       mand completed normally.

SEE ALSO

       scsi_ifgetcap(9F),      scsi_init_pkt(9F),     scsi_extended_sense(9S),
       scsi_pkt(9S)

       Writing Device Drivers

SunOS 5.11                        30 Sep 1996              scsi_arq_status(9S)
Impressum