scsi_asc_key_strings(9S) Data Structures for Drivers scsi_asc_key_strings(9S)

 scsi_asc_key_strings - SCSI ASC ASCQ to message structure

 #include <sys/scsi/scsi.h>

 Solaris DDI specific (Solaris DDI).

 The scsi_asc_key_strings structure stores the ASC and ASCQ codes and a
 pointer to the related ASCII string.

 ushort_t asc; /* ASC code */
 ushort_t ascq; /* ASCQ code */
 char *message; /* ASCII message string */

 asc Contains the ASC key code.

 ascq Contains the ASCQ code.

 message Points to the NULL terminated ASCII string
 describing the asc and ascq condition

 scsi_vu_errmsg(9F)

 ANSI Small Computer System Interface-2 (SCSI-2)

 Writing Device Drivers

SunOS 5.11 24 Feb 1998 scsi_asc_key_strings(9S)