streamtab(9S) Data Structures for Drivers streamtab(9S)

 streamtab - STREAMS entity declaration structure

 #include <sys/stream.h>

 Architecture independent level 1 (DDI/DKI).

 Each STREAMS driver or module must have a streamtab structure.

 streamtab is made up of qinit structures for both the read and write
 queue portions of each module or driver. Multiplexing drivers require
 both upper and lower qinit structures. The qinit structure contains the
 entry points through which the module or driver routines are called.

 Normally, the read QUEUE contains the open and close routines. Both the
 read and write queue can contain put and service procedures.

 struct qinit *st_rdinit; /* read QUEUE */
 struct qinit *st_wrinit; /* write QUEUE */
 struct qinit *st_muxrinit; /* lower read QUEUE*/
 struct qinit *st_muxwinit; /* lower write QUEUE*/

 qinit(9S)

 STREAMS Programming Guide

SunOS 5.11 11 Apr 1991 streamtab(9S)