miocnak(9F)              Kernel Functions for Drivers              miocnak(9F)

NAME

       miocnak - Negatively acknowledge an M_IOCTL message

SYNOPSIS

       #include <sys/stream.h>
       #include <sys/strsun.h>

       void miocnak(queue_t *wq, mblk_t *mp, int count, int error);

INTERFACE LEVEL

       Solaris DDI specific (Solaris DDI).

PARAMETERS

       wq       Write  queue associated with the read queue to send the M_IOC‐
                NAK on.

       mp       M_IOCTL message.

       count    Value to set the ioc_count of the iocblk(9S) to.

       error    Value to set the ioc_error of the iocblk(9S) to.

DESCRIPTION

       The miocnak() function converts an M_IOCTL  message  into  an  M_IOCNAK
       message and sends the resulting message upstream.

       To convert the message, miocnak() changes the message type to M_IOCNAK,
       sets the ioc_count and ioc_error members of the  iocblk(9S)  associated
       with  mp to the passed-in values, and clears the ioc_rval field.  Since
       payloads cannot currently be associated with M_IOCNAK  messages,  count
       must always be zero. If error is passed as zero, EINVAL is assumed.

RETURN VALUES

       None.

CONTEXT

       This function can be called from user, kernel or interrupt context.

NOTES

       Callers must not hold any locks across a miocnak() that can be acquired
       as part of put(9E) processing.

SEE ALSO

       mioc2ack(9F), miocack(9F), put(9E), iocblk(9S)

       STREAMS Programming Guide

SunOS 5.11                        9 June 2004                      miocnak(9F)
Impressum