qenable(9F) Kernel Functions for Drivers qenable(9F)

 qenable - enable a queue

 #include <sys/stream.h>
 #include <sys/ddi.h>

 void qenable(queue_t *q);

 Architecture independent level 1 (DDI/DKI).

 q Pointer to the queue to be enabled.

 The qenable() function adds the queue pointed to by q to the list of
 queues whose service routines are ready to be called by the STREAMS
 scheduler.

 The qenable() function can be called from user, interrupt, or kernel
 context.

 See the dupb(9F) function page for an example of the qenable().

 dupb(9F)

 Writing Device Drivers

 STREAMS Programming Guide

SunOS 5.11 16 Jan 2006 qenable(9F)