plot(4B) SunOS/BSD Compatibility Package File Formats plot(4B)

 plot - graphics interface

 Files of this format are interpreted for various devices by commands
 described in plot(1B). A graphics file is a stream of plotting instruc‐
 tions. Each instruction consists of an ASCII letter usually followed by
 bytes of binary information. The instructions are executed in order. A
 point is designated by four bytes representing the x and y values; each
 value is a signed integer. The last designated point in an l, m, n, or
 p instruction becomes the ``current point'' for the next instruction.

 m Move: the next four bytes give a new current point.

 n Cont: draw a line from the current point to the point given by
 the next four bytes. See plot(1B).

 p Point: plot the point given by the next four bytes.

 l Line: draw a line from the point given by the next four bytes to
 the point given by the following four bytes.

 t Label: place the following ASCII string so that its first charac‐
 ter falls on the current point. The string is terminated by a
 NEWLINE.

 a Arc: the first four bytes give the center, the next four give the
 starting point, and the last four give the end point of a circu‐
 lar arc. The least significant coordinate of the end point is
 used only to determine the quadrant. The arc is drawn counter-
 clockwise.

 c Circle: the first four bytes give the center of the circle, the
 next two the radius.

 e Erase: start another frame of output.

 f Linemod: take the following string, up to a NEWLINE, as the style
 for drawing further lines. The styles are ``dotted,'' ``solid,''
 ``longdashed,'' ``shortdashed,'' and ``dotdashed.'' Effective
 only in plot 4014 and plot ver.

 s Space: the next four bytes give the lower left corner of the
 plotting area; the following four give the upper right corner.
 The plot will be magnified or reduced to fit the device as
 closely as possible.

 Space settings that exactly fill the plotting area with unity
 scaling appear below for devices supported by the filters of
 plot(1B). The upper limit is just outside the plotting area.

 In every case the plotting area is taken to be square; points outside
 may be displayable on devices whose face is not square.

 4014 space(0, 0, 3120, 3120);

 ver space(0, 0, 2048, 2048);

 300, 300s space(0, 0, 4096, 4096);

 450 space(0, 0, 4096, 4096);

 graph(1), plot(1B)

SunOS 5.11 18 Feb 2003 plot(4B)