ddi_get_parent(9F) Kernel Functions for Drivers ddi_get_parent(9F)

 ddi_get_parent - find the parent of a device information structure

 #include <sys/ddi.h>
 #include <sys/sunddi.h>

 dev_info_t *ddi_get_parent(dev_info_t *dip);

 Solaris DDI specific (Solaris DDI).

 dip Pointer to a device information structure.

 The ddi_get_parent() function returns a pointer to the device informa‐
 tion structure which is the parent of the one pointed to by dip.

 The ddi_get_parent() function returns a pointer to a device information
 structure.

 The ddi_get_parent() function can be called from user, interrupt, or
 kernel context.

 Writing Device Drivers

SunOS 5.11 16 Jan 2006 ddi_get_parent(9F)