noenable(9F) Kernel Functions for Drivers noenable(9F)

 noenable - prevent a queue from being scheduled

 #include <sys/stream.h>
 #include <sys/ddi.h>

 void noenable(queue_t *q);

 Architecture independent level 1 (DDI/DKI).

 q Pointer to the queue.

 The noenable() function prevents the q from being scheduled for service
 by insq(9F), putq(9F) or putbq(9F) when enqueuing an ordinary priority
 message. The queue can be re-enabled with the enableok(9F) function.

 The noenable() function can be called from user, interrupt, or kernel
 context.

 enableok(9F), insq(9F), putbq(9F), putq(9F), qenable(9F)

 Writing Device Drivers

 STREAMS Programming Guide

SunOS 5.11 16 Jan 2006 noenable(9F)