qunbufcall(9F) Kernel Functions for Drivers qunbufcall(9F)

 qunbufcall - cancel a pending qbufcall request

 #include <sys/stream.h>
 #include <sys/ddi.h>

 void qunbufcall(queue_t *q, bufcall_id_t id);

 Solaris DDI specific (Solaris DDI).

 q Pointer to STREAMS queue_t structure.

 id Identifier returned from qbufcall(9F).

 The qunbufcall() function cancels a pending qbufcall() request. The
 argument id is a non-zero identifier of the request to be cancelled. id
 is returned from the qbufcall() function used to issue the cancel
 request.

 The qunbufcall() function is tailored to be used with the enhanced
 STREAMS framework interface which is based on the concept of perime‐
 ters. (See mt-streams(9F).) qunbufcall() returns when the bufcall has
 been cancelled or finished executing. The bufcall will be cancelled
 even if it is blocked at the perimeters associated with the queue. All
 outstanding timeouts and bufcalls must be cancelled before a driver
 close routine can block and before the close routine calls qproc‐
 soff(9F).

 The qunbufcall() function can be called from user, interrupt, or kernel
 context.

 mt-streams(9F), qbufcall(9F), qtimeout(9F), quntimeout(9F)

 Writing Device Drivers

 STREAMS Programming Guide

SunOS 5.11 16 Jan 2006 qunbufcall(9F)