usb_get_max_pkts_per_isoc_KreerqnueelstF(u9nFc)tionsufsobr_gDerti_vmearxs_pkts_per_isoc_request(9F)

 usb_get_max_pkts_per_isoc_request - Get maximum number of packets
 allowed per isochronous request

 #include <sys/usb/usba.h>

 uint_t usb_get_max_pkts_per_isoc_request(dev_info_t *dip);

 Solaris DDI specific (Solaris DDI)

 dip Pointer to the device's dev_info structure.

 The usb_get_max_pkts_per_isoc_request() function returns the maximum
 number of isochronous packets per request that the host control driver
 can support. This number can be used to determine the maximum amount of
 data which can be handled by a single isochronous request. That length
 is found by:

 max = usb_get_max_pkts_per_isoc_request(dip) * endpoint_max_packet_size;

 where endpoint_max_packet_size is the wMaxPacketSize field of the
 isochronous endpoint over which the transfer will take place.

 On success, the usb_get_current_frame_number() function returns the
 maximum number of isochronous pkts per request. On failure it returns
 0. The function fails if dip is NULL.

 May be called from user, kernel or interrupt context.

 /*
 * Set up to receive periodic isochronous data, requesting
 * the maximum amount for each transfer.
 */

 int pkt;
 /* Get max packet size from endpoint descriptor. */
 uint_t ep_max_pkt_size = ep_descr.wMaxPacketSize;
 uint_t isoc_pkts_count = usb_get_max_pkts_per_isoc_request(dip);

 /*
 * Allocate an isoc request, specifying the max number of packets
 * and the greatest size transfer possible.
 */
 usb_isoc_req_t *isoc_req = usb_alloc_isoc_req(dip,
 isoc_pkts_count,
 isoc_pkts_count * ep_max_pkt_size,
 USB_FLAGS_SLEEP);

 /* Init each packet descriptor for maximum size. */
 for (pkt = 0; pkt < isoc_pkts_count; pkt++) {
 isoc_req->isoc_pkt_descr[pkt].isoc_pkt_length = ep_max_pkt_size;

 }

 /* Set the length of a packet in the request too. */
 isoc_req->isoc_pkts_length = ep_max_pkt_size;

 /* Other isoc request initialization. */
 ...
 ...

 if (usb_pipe_isoc_xfer(pipe, isoc_req, USB_FLAGS_NOSLEEP) != USB_SUCCESS) {
 ...
 }

 See attributes(5) for descriptions of the following attributes:

 ┌─────────────────────────────┬─────────────────────────────┐
 │ ATTRIBUTE TYPE │ ATTRIBUTE VALUE │
 ├─────────────────────────────┼─────────────────────────────┤
 │Architecture │PCI-based systems │
 ├─────────────────────────────┼─────────────────────────────┤
 │Interface stability │Committed │
 ├─────────────────────────────┼─────────────────────────────┤
 │Availability │SUNWusb │
 └─────────────────────────────┴─────────────────────────────┘

 attributes(5), usb_pipe_isoc_xfer(9F), usb_alloc_request(9F),
 usb_get_current_frame_number(9F). usb_ep_descr(9S),
 usb_isoc_request(9S)

SunOS 5.11 5 Jan 20u0s4b_get_max_pkts_per_isoc_request(9F)