module_info(9S) Data Structures for Drivers module_info(9S)

 module_info - STREAMS driver identification and limit value structure

 #include <sys/stream.h>

 Architecture independent level 1 (DDI/DKI).

 When a module or driver is declared, several identification and limit
 values can be set. These values are stored in the module_info struc‐
 ture.

 The module_info structure is intended to be read-only. However, the
 flow control limits (mi_hiwat and mi_lowat) and the packet size limits
 (mi_minpsz and mi_maxpsz) are copied to the QUEUE structure, where they
 can be modified.

 For a driver, mi_idname must match the name of the driver binary file.
 For a module, mi_idname must match the fname field of the fmodsw struc‐
 ture. See fmodsw(9S) for details.

 ushort_t mi_idnum; /* module ID number */
 char *mi_idname; /* module name */
 ssize_t mi_minpsz; /* minimum packet size */
 ssize_t mi_maxpsz; /* maximum packet size */
 size_t mi_hiwat; /* high water mark */
 size_t mi_lowat; /* low water mark */

 The constant FMNAMESZ, limiting the length of a module's name, is set
 to eight in this release.

 fmodsw(9S), queue(9S)

 STREAMS Programming Guide

SunOS 5.11 26 Nov 2002 module_info(9S)