qband(9S) Data Structures for Drivers qband(9S)

 qband - STREAMS queue flow control information structure

 #include <sys/stream.h>

 Architecture independent level 1 (DDI/DKI)

 The qband structure contains flow control information for each prior‐
 ity band in a queue.

 The qband structure is defined as type qband_t.

 struct qband*qb_next; /* next band's info */
 size_t qb_count /* number of bytes in band */
 struct msgb *qb_first; /* start of band's data */
 struct msgb *qb_last; /* end of band's data */
 size_t qb_hiwat; /* band's high water mark */
 size_t qb_lowat; /* band's low water mark */
 uint_t qb_flag; /* see below */

 Valid flags are as follows:

 QB_FULL Band is considered full.

 QB_WANTW Someone wants to write to band.

 strqget(9F), strqset(9F), msgb(9S), queue(9S)

 STREAMS Programming Guide

 All access to this structure should be through strqget(9F) and
 strqset(9F). It is logically part of the queue(9S) and its layout and
 partitioning with respect to that structure might change in future
 releases. If portability is a concern, do not declare or store
 instances of or references to this structure.

SunOS 5.11 14 Nov 1996 qband(9S)